MS Word and PDF Accessibility Checklists
What is an accessible document?

An accessible document is one in which users living with a disability can understand the content of the document, or have
the content read back to them via a text reader.

Types of disability:
* Visual impairment
* Mobility issues
+ Cognitive issues

Word Checklist:

Check | Description

v Run the Accessibility Checker on Word documents: (File -> Check for issues -> Check Accessibility)

v Provide alternative text for images (point #1 below)

v Provide document headings and structure (point #2 below)




Check | Description

v Create a table of contents (point #3 below)

v Ensure text and fonts are accessible (point #4 below)
v Delete repeated ‘blank’ characters (point #5 below)
v Ensure correct use of tables (point #6 below)

v Provide descriptive hyperlinks (point #7 below)

v Use simple bulleted lists (point #8 below)

Things to consider when fixing or creating an accessible Word document:

1. Alternative (or Alt) text

Provide alternative text for images
Alt text helps people who use screen readers to understand the content of images and tables in your document. For many
readers, this is the only information they have about the images and objects in your document.

Recommendations:

e Allimages (and even tables!) should have an Alt Text description
o Make the Alt Text clear and concise: “Students using computers in a classroom” tells the reader more about the
image than just “Students”



2. Document structure (using headings)
Provide document headings and structure

Headings allow users of assistive technologies, such as screen readers, to navigate through the page easily. When you
use headings in a document, try to keep them short and on one line.

Recommendations:

e Headings should provide a well ordered structure to the document

e Headings should be created using the ‘Styles’ formatting at the top of the page

e Headings should not be created by simply changing the font type, the font size, or making it bold, etc.

e Follow a logical heading order, e.g. ‘Heading 1’ followed by ‘Heading 2’ then ‘Heading 3’. Do not skip the logical
order by going from a ‘Heading 1’ to a ‘Heading 3'.

3. A Table of Contents (for longer documents)

Creating a table of contents

A Table of contents provides an overview of what is in the document and helps all readers quickly and easily find a
particular section within the document. To insert a Table of Contents, click on the ‘REFERENCES’ tab, then ‘Table of
Contents’.

Recommendations:
e A Table of contents should be provided when creating a large Word document
e By using well-structured headings, MS Word can use these headings to create a Table of contents within the
document



4. Accessible text and fonts

* Text should not be made as graphics. Avoid using “Word Art” to create text
+ Text should be basic, simple and easy to read, using plain language

* Avoid small font sizes

* Use good colour contrast between the text and background

* Avoid use of colour to convey important information

* Provide sufficient spacing between lines

« There should be at least a one-line space between paragraphs

« Best fonts for low vision users: Arial or Verdana. Font size: 11 or 12 pt

* Avoid ‘justified text’. The spacing between words becomes inconsistent in length and can be distracting to some
people

5. Deleting repeated ‘blank’ characters

Extra spaces and empty paragraphs may be perceived as blanks by people using screen readers.

After hearing a screen reader say “blank” several times, those users may think that they have reached the end of the
document.

Instead of blank characters and spaces, use paragraph formatting and tabs to create whitespace.

6. Correct use of tables
Tables should be used for tabular data.

Provide table headers
Adding headers to tables provides context and helps users of assistive technologies navigate the table.

Recommendations:



e The data table header cells must be clearly defined to distinguish the heading text from the data area of the table

e Repeat the header cells (useful if the table spans more than one page)

¢ Avoid using complex headers

e Tables should be used to present columns and rows of data. Blank table cells can mislead a person using a text
reader into thinking there’s no more content. Delete unnecessary blank cells.

7. Descriptive hyperlinks

Hyperlinks should provide a clear and precise description that explains the purpose and destination of the link, e.g. For
more information visit the George Brown College website.

Unclear link examples that should not be used:

e Click here / here
e More / Read more
e Link to [some long URL]

A list of all hyperlinks can be pulled from a document and read back to a person using a screen reader. For this reason,
avoid using URLs as hyperlinks, as the text reader will read out loud a whole list of URLs that don’t have much meaning
for a user of such assistive technology.

8. Bulleted lists

Try to avoid the use of images or arrows when created bulleted lists. Stick with the standard ‘bullet’ ¢
wherever possible. List itern £1

List item #2
Example (see bullet points on the right): List item #3



Note: The above bulleted style is also in keeping with the GBC Writing Style Guide available on the Self-Publishing
System website (http://sps.georgebrown.ca/) under ‘GUIDELINES | Writing Style’



PDF Checklist:

Check | Description

v Ensure the document ‘Properties’ (or metadata) have been inputted correctly (Title, Author, Subject, Keywords)
(point #9 below)

v Ensure images contain alternate (Alt) text, or are ‘backgrounded’ (point #10 below)

v Tag content for screen readers (point #11 below)

v Check that a logical reading order has been established (point #12 below)

v Make sure tables are tagged to represent the table structure (point #13 below)
v Ensure form fields and other interactive features are tagged (point #14 below)
v Create ‘Bookmarks’ for longer documents (point #15 below)

v Check document structure (or headings) (point #16 below)




Things to consider when fixing or creating PDFs:

9. Document ‘Properties’ (or metadata) have been set

There are four document properties that need to be set in a PDF: Title, Subject,
Author and Keywords. They can be added or modified manually by going to File
> Properties and then filling in the four fields under the Description tab.

Note

Keywords should be separated by semi-colons.
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Also, make sure Document Title is selected in the drop-down menu to the right of Show, under the Initial View tab.

Document Properties I ‘ I ;
| Description I Security I Fonts { Initial View Lustom | Advanced|

Layout and Magnification

Navigation tab: [Page Only v]
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Window Options
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10. Images contain alternate (Alt) text, or are ‘backgrounded’

When an image is tagged as a figure, the alternative text will appear in a black box in the upper left hand corner of the
image. If it has no alternative text, the caption will read "Figure - No alternate text exists."

anigure - No alternate text exists.

To add or edit alternative text, right click on the image and select Edit Alternate Text. Enter the appropriate alternative
text in the dialog box.

Backgrounding, or Artifacts, are elements that are ignored by a screen reader, much like an image with empty alternative
text in HTML. Important text should never be labeled as an artifact. The easiest way to change an element to or from an
artifact is with the Touch Up Reading Order tool (TURO). Select the element and press the Background button to make it
an artifact.

To search for artifacts, go to the Tags pane and select Options > Find. A window will appear with several search options.
Artifact is the default search, so click Find. If there are any artifacts, the search will identify them and allow you to change
them to other elements.

To change a tag to an artifact in the Tags pane, right click on the item and select Change Tag to Artifact.

11. Tags have been created and validated for all content

When people talk about "accessible" PDF files, they usually are referring to "tagged" PDF files, even though there is more
to an accessible PDF than tags. PDF tags provide a hidden structured, textual representation of the PDF content that is
presented to screen readers. They exist for accessibility purposes only and have no visible effect on the PDF file.


http://webaim.org/techniques/alttext/
http://webaim.org/techniques/alttext/

12. A logical reading order has been established

The TouchUp Reading Order (or TURO) tool allows a user to add and edit many common PDF tags, and to view the
content order of elements on the page. Although it can speed up the tagging process, it does not take the place of the
other tools mentioned previously. Certain tags, such as lists, are only available in the Tags pane.

To use the TURO tool, select Tools from the right-hand menu, then

select Accessibility > TouchUp Reading Order. If the Accessibility menu is not
visible (it is hidden in version Xl by default), make sure it is checked in the option menu
(E=) in the upper-right corner of the Tools sidebar. When the TURO tool is selected,
the view on the screen changes. All of the content is enclosed in numbered boxes.
Each of these numbered boxes corresponds with the content order of the PDF, as
reflected in the order pane.Content Order

There are actually three different types of 'reading order' within a PDF: the visual order
that most people see when viewing a PDF, the tags order that is accessed by screen
readers and other assistive technologies, and the lesser-known content order that is
used by Adobe when a user selects Reflow or Read Out Loud options.

While the goal is to get these three views to match, this is not always easy to
accomplish. For example, if a PDF is created from a MS Word DOCX file, text boxes
and images usually appear in the correct place in the tags order, but they typically
appear at the end of the page in content order.

Important

The TURO tool displays the content order of the PDF, NOT the tags order. Reading
order can appear correct in this view but the PDF may still be read incorrectly by a
screen reader (or vice versa). Only the Tags Pane provides a true indication order that
content will be read by a screen reader.

Touch Up Reading Crder

Draw a rectangle around the content then click
one of the buttons below:

| Text | | Figure

| Form Field | | Figure/Caption

| Heading 1 | | Heading 4 | | Table

| Heading2 | | Headings | | Cel

| Heading 3 | | Heading & | | Formula

| Background

V| Show page content groups [ ]
@ Page content order
Structure types
V| Show table cells [ ]
| Display like elements in a single block

V| Show tables and figures [ ]

Clear Page Structure... | | Show Order Panel

Help | | Close

The TouchUp Reading Order window includes several options to change tags within a page.




You will notice a group of buttons with the names of several common tags. You can use these buttons to assign tags to a
selected block of text or an object.

Note
If you have the TURO tool open and don't see any boxes, your PDF document is most likely untagged.

Adding/Changing tags

There are two ways to select an area of text, image, table, or other element using TURO:

1. Drag a box around an element using the crosshairs "+~ that have replaced the default pointer. It is sometimes
difficult to select exactly the right area, but it is a little easier if you try drawing a box that is slightly larger than the
element. Once you have selected a new element, you can assign some of the most common tags to that element
by clicking on one of the several buttons.

2. You can also select everything within a box by clicking on the number in the top-left corner.

Now that you have selected the text, you can assign a tag by clicking on the corresponding button. Once you select a
button, Acrobat will place the selected content in the appropriate tag. If you have the Tags pane open, you can view these
changes instantly.

While in TURO, you can also assign alternate text to images by right-clicking on the image and choosing Edit Alternate
Text.



13. Tables are correctly tagged to represent the table structure

The Table Inspector allows you to easily identify and assign scope to
table headers.

With the Touch Up Reading Order tool (TURO) tool open, select a table
and then select Table Inspector. You can now select table cells that
should be headers. Right click on a selected cell or cells and choose
Table Cell Properties. A dialog box will appear.

If the selected cell(s) needs to be tagged as a header (<TH>), select
the Header Cell option and assign a scope of either Row or Column.
After selecting OK, you will notice that the table header cells will be
highlighted in red and the data cells will be highlighted in gray.

Header Header Header
Data Data Data
Data Data Data
Data Data Data |

14. Form fields and other interactive features are tagged to ensure their maximum usability
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Just as "tags" are essential to the accessibility of a PDF file, true form fields and buttons are essential to the accessibility
of a PDF form. This allows the form to be filled out and submitted within Adobe Reader.

Note

You can easily check to see if a PDF form has the necessary fields by opening the file in Acrobat or Adobe Reader. If
the Highlight Existing Field option is visible in a purple bar at the top of the page, this means the PDF already has form

fields.



15. Bookmarks for longer documents are in place

Bookmarks help all users to navigate through your document and are especially useful for longer documents. To create
bookmarks, Click on the Bookmarks icon in the left hand column (see below), then select the text you’'d like to bookmark
and then click the New Bookmark icon in the Bookmarks panel. Hit Enter to then create the new bookmark.
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16. Document structure (or headings)

Make sure all headings within the PDF follow a logical, structured order, i.e. H1 is followed by H2, which in turn is followed
by H3, etc. Do not skip a heading level by going from an H1 to an H3, for example.

Note: Text for PDF Checklist was originally derived from WebAIM (http://webaim.org/) and used with permission. This text remains ©2015
WebAIM
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